Notice: wpdb::prepare est appelée de la mauvaise manière. The query does not contain the correct number of placeholders (2) for the number of arguments passed (3). Please see Debugging in WordPress for more information. (Ce message a été ajouté à la version 4.8.3.) in /data/www/subsurface/wp-includes/functions.php on line 4161
Download Subsurface for Windows, MacOS, Linux

Télécharger

Windows

subsurface-4.8.1.exe est un logiciel 32/64 bit, testé sur Windows 7, Windows 8 et Windows 10.

Mac

Subsurface-4.8.1.dmg est une image Mac qui peut être installée, sur les Macs Intel 64 bits utilisant MacOS 10.10 ou plus récent, en plaçant le fichier Subsurface.app dans votre dossier /Applications.

Linux

Nous proposons une installation simple à partir de nos propres binaires pour plusieurs versions de Linux.

Ubuntu (14.04 -- only up to Subsurface 4.6.4, 16.04, 16.10 (up to 4.6.4), and 17.04), LinuxMint (17 (up to 4.6.4) and 18), and Debian Jessie (up to 4.6.4) and Stretch

Pour utiliser ces binaires depuis Ubuntu, ajouter simplement le PPA suivant à votre système :

ppa:subsurface/subsurface
  • Ouvrir le centre de logiciels Ubuntu
  • Edition –> Sources de logiciels
  • Autres logiciels –> Ajouter –> ppa:subsurface/subsurface
  • Fermer et rechercher Subsurface. Installer.

Il semble que sur Linux Mint, il faut utiliser les lignes de commande suivantes, sinon l’ancienne version 4.0 est installée :

sudo apt-add-repository ppa:subsurface/subsurface
sudo apt-get update
sudo apt-get install subsurface=4.8.1-1~xenial

Pour Debian Jessie, il faut ajouter le dépôt Ubuntu :

echo "deb http://ppa.launchpad.net/subsurface/subsurface/ubuntu xenial main" 
        | sudo tee /etc/apt/sources.lists.d/subsurface.list
gpg --keyserver subkeys.pgp.net --recv-keys A8BC9756EE61D9C6
gpg -a --export A8BC9756EE61D9C6 | sudo apt-key add -
sudo apt-get update

Pour les distributions qui ne supportent que l’ancienne version Subsurface, remplacez xenial par trusty .

Il suffit à présent d’installer Subsurface depuis le dépôt :

sudo apt-get install subsurface

Assurez-vous d’obtenir la dernière version avec toutes les dépendances Qt5.

OpenSUSE Leap 42.1, Leap 42.2, Leap 42.3, Tumbleweed and Fedora 24, 25, 26, 27

Pour installer les paquets Subsurface officiels sous openSUSE ainsi que Fedora, allez sur our build service project page et suivez les instructions, simplement quelques clics.

All other 64bit Linux versions

A generic AppImage is available for download as Subsurface-4.8.1-x86_64.AppImage. You should be able to download this file, make it executable chmod +x Subsurface-4.8.1-x86_64.AppImage and then simply run this file. We are very interested in feedback regarding this way of distributing Linux binaries.

Paquets maintenus par les distributions obsolètes

Plusieurs distributions Linux permettent d’installer Subsurface à partir de l’OS. C’est pratique mais les versions offertes sont obsolètes et ne sont pas compilées avec nos propres bibliothèques, donc les paquets officiels de Subsurface (tels qu’ils sont disponibles à présent) devraient être un bien meilleur choix.

Sources

Les sources de Subsurface sont bien sûr disponibles via git ou sous forme d’une archive : Subsurface-4.8.1.tgz Les sources des composants GPL et LGPL incluses dans les binaires pour Windows et Mac OS peuvent être trouvées via MacPorts et MinGW.